System requirements

Here are the various system requirements for our DragonBox Algebra games. We currently have two different apps available for purchase through all major app stores, and one school product playable in the browser and available for purchase for schools in Scandinavia and the USA.

Platform DragonBox Algebra 5+ DragonBox Algebra 12+ DragonBox Algebra 12+ EDU DragonBox Elements
IOS Supported(1)
Android Supported(2) Planned Supported(2)
Mac OS X Supported(3) Planned Supported(6) Planned
Windows XP, Vista, 7 Supported(4)
Planned Supported(6) Planned
Windows 8 Store Supported(5) Supported(5) N/A Planned
WebPlayer N/A N/A Supported(6) N/A
Flash N/A N/A Deprecated(7) N/A

(1) Requires iOS 4.0+ & armv7 processor i.e. Compatible with iphone since the 3gs, all ipads and ipods since the 3rd generation except for the 8GB of the 3rd generation (MC086LL). Older ipods (like first generation ipod touch) are not supported [source].

(2) C
ompatible with all but oldest android phones and tablets. Requires Android 2.3+ & armv7. Tested on several android phones including (but not limited to) Samsung Galaxy S, SII, Tab 10.1, LG Optimus, HTC Sense, HTC, Google Nexus, Kindle.

The exact list of supported phones is not available at the moment. You can usually find out if a phone will be compatible by identifying on a site like gsmarena.com the android verison and the chipset your phone has. E.g. the Sony Xperia Arc S has a Qualcomm MSM8255 Snapdragon chipset. Then by searching that chipset name, you will find the CPU instruction set on the internet. Wikipedia often has that information. For the aforementioned chipset it is armv7, thus compatible. Send us a mail if you're unsure.

(3) Mac OS X 10.6.6 or above.

(4) XP SP2 or more

Graphics card with DirectX 9 level (shader model 2.0) capabilities. Any card made since 2004 should work.

(5) Windows Store should filter incompatible devices. We haven't set specific extra requirements.

(6) See the Unity3D WebPlayer specific requirements. It is recommended to use it on a computer with suitable Direct X 9 driver and at least 1G RAM.

(7) The flash player is not recommended. If used, the flash version currently requires flash v11.5 or later, this means it won't work on Linux. See the flash player specific requirements. It is recommended to use it on a computer with suitable Direct X 0 driver and at least 1G RAM

The WeWantToKnow EDU also requires a recent browser. In particular IE7 and IE8 are not supported.

Note: a few devices supposedly compatible are exhibiting unfixable bugs, and have been excluded from the Google Play store. 


 We recommend you to contact us for any questions regarding hardware requirements.

Feedback and Knowledge Base